Installation

Before installing the PowerJSON official JavaScript, Node.js parser, you need to know the following:

Compatibility

PowerJSON JavaScript (running in the browser) Parser support:

  • IE >= 11
  • Edge All
  • Firefox >= 6
  • Chrome >= 21
  • Safari >= 7.1
  • Opera >= 15

PowerJSON Node.js parser support:

  • Node.js >= 6

Version

Latest version: 1.0.0-alpha

JS parser installation

Introduced directly with <script>

Directly downloaded and introduced with the <script> tag, PJSON will be registered as a global variable.

Go to Github to download now!

CDN

For the development environment, you can use it directly:

<script src="https://cdn.jsdelivr.net/npm/@powerjson/powerjson/index.js"></script>

To introduce the latest version of the PowerJSON JavaScript interpreter.

For production environments, we recommend linking to a clear version number to avoid unpredictable damage caused by the new version:

<script src="https://cdn.jsdelivr.net/npm/@powerjson/powerjson@version/index.js"></script>

NPM

An NPM installation is recommended when building large applications with PowerJSON. NPM works well with packagers such as Webpack or Browserify modules.

$ npm install @powerjson/powerjson

Please Visit NPM.